ESP8266 ESP07


En nadat alles goed ging bij het Yellowboard en bij de NodeMcu durfde ik het aan de de losse Esp07.
3.3V Voeding via een uit China gekochte voeding stabilisator. De Usb naar FTDI omzetter die ik gebruikte voor de Yellowboard. Dat moest dus lukken.
Okee de travo aan, kijken of alle leds gaan branden zodat ik weet dat ik voedingspanning heb.
Dan GPIO 0 aan de min (FLASH) en RST kortstondig aan de min. Vervolgens ruik ik de voeding. Het opgenomen vermogen loop dusdanig op dat mijn stabilisatie erg heet wordt.
Eerst dus maar eens kijken hoe ik dat kan oplossen.
Om te flashen moet:
GPIO 0: Laag(min)
GPIO 2: Hoog(plus)
GPIO 15: laag(min)
verbonden zijn.
Op de site van Zoetrope vinden we de verschillende boot opties.
Status GPIO 0 GPIO 2 GPIO 15
UART Download Mode (Programming) 0 1 0
Flash Startup (Normal) 1 1 0
SD-Card Boot 0 0 1
12-4-2016.
Op een extern testboard verder aan het experimenteren.
De RX aan de TX en de TX aan de RX. De min aan de min en dan kan de USB naar FTDI verbinding maken.
Nu met een lab voeding die wat meer kan leveren. Vandaar dat de stabilisator warm werd. Die kon max. 300mAmp leveren.

Nu krijg ik weer een board fout.
Bord nodemcu (platform esp8266, package esp8266) ongekend
Error compiling for board NodeMCU 0.9 (ESP-12 Module).

Hoe kom ik daar nu weer aan?
Na wat geGoogeld kwam de melding ga terug naar Arduino versie 1.6.5. Dus die weer gedownload, opnieuw bij voorkeur 'http://arduino.esp8266.com/stable/package_esp8266com_index.json' gekozen en board ESP8266, voorbeeld Blink.
En inderdaad dat werkt. Ik krijg tenminste nu geen fout melding als ik de sketch alleen mar 'build'.
Nu krijg ik alleen de melding als ik wil uploaden:
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
Al met al weer een hele dag alleen maar dingen geleerd wat niet werkt.;-)


Bronnen:
communicatie maken
Error oplossingen sparkfun